Apple iPhone Exchange IMAP Issues

Been playing with the iPhone since I got it at about 6:45Pm on June 29th and the first aspect that I wanted to test was the ability to connect to our corporate Exchange server. Had to allow IMAP through the firewall first and configure the Exchange (2003) server to allow SSL IMAP connections. After some initial problems getting the iPhone to connect I was successful in getting connected.

So my email shows up and all the subfolders of email show up, attachment viewing great, but the major problem / challenge I am running into now is the email only syncs one way. If I delete a message from the iPhone it never deletes it from the server. It will mark the message as being read but thats about it. I am going to try it on another Exchange server to see if its any better on another installation of Exchange 2003. So close yet so far away!

3 comments:

BigAirSkier said...

I noticed that you have Microsoft Exchange 2003. My company is using the same version and I have been not been able to get mine to work properly. I have followed all of the steps that you illustrate, and after many hours I am finally able to send emails but not recieve or view any of my past emails. When I click the inbox heading it says "loading 25 lastest messages" but nothing ever comes up. Is there a special patch or update specigically for 2003. I noticed that if you have 2007 there is a patch called rollup 3. Any help would be appreciated.

Thank You, John Foster

Mike said...

Actually that is exactly how imap works...

Perry said...

Just curious if you ever found a solution to this problem as I'm experiencing the same thing. Thanks!!